<!DOCTYPE html>
<html lang='en'>
<head id="head"><title>
	Marvin Agustin reveals greatest reward of being a dad |  ABS-CBN News
</title><meta name="robots" content="index,follow" /><meta http-equiv="x-ua-compatible" content="ie=edge,chrome=1" /><meta content="text/html; charset=utf-8" http-equiv="content-type" /><meta name="viewport" content="width=device-width, initial-scale=1.0" /><meta name="keywords" content="Marvin Agustin, I Feel U, parenting, Marvin Agustin reveals greatest reward of being a dad | ABS-CBN News" /><meta name="description" content="Marvin Agustin is mostly known as the actor or the entrepreneur but not a lot of people know how he is a father to his twin sons.
&nbsp;
" /><meta name="copyright" content="All rights reserved by ABS-CBN Corporation" /><meta name="news_keywords" content="Marvin Agustin, I Feel U, parenting, Marvin Agustin reveals greatest reward of being a dad | ABS-CBN News" /><meta name="articleID" content="662632" /><meta name="article_id" content="article-662632" /><meta name="article-tags" content="Marvin Agustin, I Feel U, parenting" /><meta name="section" content="Entertainment" /><meta name="thumbnail" content="https://sa.kapamilya.com/absnews/abscbnnews/media/2020/entertainment/08/03/marvin-agustin.jpg" /><meta name="author" content="ABS-CBN News" /><meta name="category" content="Entertainment" /><meta name="pubdate" content="2020-08-03T04:27:47+00:00" /><meta name="published_date" content="2020-08-03T04:27:47+00:00" /><meta name="lastmod" content="2020-08-03T04:27:48+00:00" /><meta name="medium" content="article"><meta property="og:title" content="Marvin Agustin reveals greatest reward of being a dad" /><meta property="og:description" content="Marvin Agustin is mostly known as the actor or the entrepreneur but not a lot of people know how he is a father to his twin sons.
&nbsp;
" /><meta property="og:url" content="https://news.abs-cbn.com/entertainment/08/03/20/marvin-agustin-reveals-greatest-reward-of-being-a-dad" /><meta property="og:image" content="https://sa.kapamilya.com/absnews/abscbnnews/media/2020/entertainment/08/03/marvin-agustin.jpg" /><meta property="og:image:alt" content="Marvin Agustin reveals greatest reward of being a dad" /><meta property="og:type" content="article" /><meta property="og:site_name" content="ABS-CBN News" /><meta property="og:locale" content="en_US" /><meta property="og:locale:alternate" content="tl_PH" /><meta name="article:published_time" content="2020-08-03T04:27:47+00:00" /><meta name="article:modified_time" content="2020-08-03T04:27:48+00:00" /><meta property="article:section" content="Entertainment" /><meta property="article:tag" content="Marvin Agustin, I Feel U, parenting, Entertainment, 2020-08-03" /><meta property="article:publisher" content="https://www.facebook.com/abscbnNEWS" /><meta property="fb:app_id" content="1710456575844989" /><meta property="fb:pages" content="27254475167" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@ABSCBNNews" /><meta name="twitter:url" content="https://news.abs-cbn.com/entertainment/08/03/20/marvin-agustin-reveals-greatest-reward-of-being-a-dad" /><meta name="twitter:title" content="Marvin Agustin reveals greatest reward of being a dad" /><meta name="twitter:description" content="Marvin Agustin is mostly known as the actor or the entrepreneur but not a lot of people know how he is a father to his twin sons.
&nbsp;
" /><meta name="twitter:image" content="https://sa.kapamilya.com/absnews/abscbnnews/media/2020/entertainment/08/03/marvin-agustin.jpg" /><link rel="canonical" href="https://news.abs-cbn.com/entertainment/08/03/20/marvin-agustin-reveals-greatest-reward-of-being-a-dad" /><link rel="amphtml" href="https://news.abs-cbn.com/amp/entertainment/08/03/20/marvin-agustin-reveals-greatest-reward-of-being-a-dad" /><link rel="image_src" href="https://sa.kapamilya.com/absnews/abscbnnews/media/2020/entertainment/08/03/marvin-agustin.jpg" /><link rel="publisher" href="https://plus.google.com/112872030600928328544" /><meta charset="UTF-8" />
<link rel="preconnect" href="//accounts.us1.gigya.com" crossorigin><link rel="preconnect" href="//ad.doubleclick.net" crossorigin><link rel="preconnect" href="//adservice.google.com" crossorigin><link rel="preconnect" href="//adservice.google.com.ph" crossorigin><link rel="preconnect" href="//assets.abs-cbn.com" crossorigin><link rel="preconnect" href="//cdn.gigya.com" crossorigin><link rel="preconnect" href="//cdns.us1.gigya.com" crossorigin><link rel="preconnect" href="//ds.us1.gigya.com" crossorigin><link rel="preconnect" href="//fonts.googleapis.com" crossorigin><link rel="preconnect" href="//fonts.gstatic.com" crossorigin><link rel="preconnect" href="//gscounters.us1.gigya.com" crossorigin><link rel="preconnect" href="//googleads.g.doubleclick.net" crossorigin><link rel="preconnect" href="//img.abs-cbnnews.com" crossorigin><link rel="preconnect" href="//imagecache.crowdynews.com" crossorigin><link rel="preconnect" href="//images.outbrain.com" crossorigin><link rel="preconnect" href="//imasdk.googleapis.com" crossorigin><link rel="preconnect" href="//log.outbrain.com" crossorigin><link rel="preconnect" href="//netdna.bootstrapcdn.com" crossorigin><link rel="preconnect" href="//news.abs-cbn.com"><link rel="preconnect" href="//odb.outbrain.com" crossorigin><link rel="preconnect" href="//pagead2.googlesyndication.com" crossorigin><link rel="preconnect" href="//sa.kapamilya.com" crossorigin><link rel="preconnect" href="//securepubads.g.doubleclick.net" crossorigin><link rel="preconnect" href="//static.crowdynews.com" crossorigin><link rel="preconnect" href="//tpc.googlesyndication.com" crossorigin><link rel="preconnect" href="//widgets.outbrain.com" crossorigin><link rel="preconnect" href="//www.google-analytics.com" crossorigin><link rel="preconnect" href="//www.google.com" crossorigin><link rel="preconnect" href="//www.googletagservices.com" crossorigin><link rel="preconnect" href="//www.youtube.com" crossorigin><link rel="preload" href="//img.abs-cbnnews.com/assets/styles/master-20180316.css" as="style"><link rel="preload" href="//assets.abs-cbn.com/universalnav/uninav-v4.2.0.css" as="style"><link rel="preload" href="//netdna.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css" as="style"><link rel="preload" href="//img.abs-cbnnews.com/assets/scripts/master.20200625.js" as="script"><link rel="preload" href="//img.abs-cbnnews.com/assets/scripts/cookie.js" as="script"><link rel="preload" href="//img.abs-cbnnews.com/assets/scripts/jquery.timeago.js" as="script"><link rel="preload" href="//img.abs-cbnnews.com/assets/scripts/slick.min.js" as="script"><link rel="preload" href="https://code.jquery.com/jquery-3.5.0.min.js" as="script"><link rel="preload" href="https://cdnjs.cloudflare.com/ajax/libs/modernizr/2.8.3/modernizr.js" as="script"><link rel="preload" href="//img.abs-cbnnews.com/2016/scripts/pie.htc"><link rel="preload" href="//assets.abs-cbn.com/universalnav/uninav-v4.2.0.js" as="script"><link rel="preload" href="//www.googletagservices.com/tag/js/gpt.js" as="script"><link rel="preload" href="https://www.google-analytics.com/analytics.js" as="script"><link rel="preload" href="//widgets.outbrain.com/outbrain.js" as="script"><link rel="preload" href="https://sa.kapamilya.com/absnews/abscbnnews/media/abs-cbnnews/abscbnmaster/newsapple-icon.png" as="image"><link rel="preload" href="https://sa.kapamilya.com/absnews/abscbnnews/media/abs-cbnnews/abscbnmaster/newsfavicon.png" as="image"><link rel="preload" href="https://sa.kapamilya.com/absnews/abscbnnews/media/abs-cbnnews/abscbnmaster/favicon.ico" as="image"><link rel="preload" href="https://sa.kapamilya.com/absnews/abscbnnews/media/abs-cbnnews/abscbnmaster/logo-abscbn.png" as="image"><link rel="preload" href="https://sa.kapamilya.com/absnews/abscbnnews/media/newsmain/theme/sprite2.png" as="image"><link rel="preload" href="//assets.abs-cbn.com/universalnav/live/img/spr-uninav.png" as="image">

<link rel="stylesheet" href="//netdna.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css" />
<link rel="stylesheet" media="screen" href="//assets.abs-cbn.com/universalnav/uninav-v4.2.0.css" />
<link rel="stylesheet" media="screen" href="//img.abs-cbnnews.com/assets/styles/master-20180316.css"> 
<script type="text/javascript" async="true" src="//img.abs-cbnnews.com/assets/scripts/modernizer.min.js"></script>
<style>
  .def-slb {
      position: static;
      display: initial;
  }
  .sticky-slb {
      position: fixed;
	  bottom: 0px;
      width: 100%;
      z-index: 8888;
      text-align: center;
      display: none;
      background-color: #000;
      padding-top: 10px;
      padding-bottom: 10px;
      left: 0 !important;
  }
  #ad-close {
    position: absolute;
    right: 4px;
    top: 5px;
    font-weight:bolder !important;
	z-index: 8889;
	color :#ffffff !important;
	font-size: 17px !important;
  }
}
</style>
<style>
.acta-article {
	padding: 10px;
	background-color: #0a1438;
	color: #fff;
	font-size: 16px;
	text-align: center;
}
.cta-text {
	margin: 0px!important;
	font-size: 18px!important;
	color: #fff!important;
}
.cta-btn {
	display: inline-block;
	margin-left: 10px;
	padding: 5px 10px;
	background-color: #ca1212;
	color: #fff;
	font-size: 14px;
	font-weight: 700;
	text-decoration: none;
	text-transform: uppercase;
	cursor: pointer;
}
.cta-btn:hover {
	background-color: #dbe2e9;
	color: #000;
}
.cta-btn a {
	color: #fff!important;
}
  @media only screen and (max-width:480px){
	.acta-article {
    margin-bottom: 20px;
	}
}
</style>
<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>
<!--[if lt IE 9]>
	<script async="true" src="//img.abs-cbnnews.com/assets/scripts/respond.min.js"></script>
	<style type="text/css">.cssie { behavior: url(//img.abs-cbnnews.com/2016/scripts/pie.htc); }</style>
<![endif]-->

<link rel="apple-touch-icon" href="https://sa.kapamilya.com/absnews/abscbnnews/media/abs-cbnnews/abscbnmaster/newsapple-icon.png">
<link rel="icon" href="https://sa.kapamilya.com/absnews/abscbnnews/media/abs-cbnnews/abscbnmaster/newsfavicon.png">
<!--[if IE]><link rel="shortcut icon" href="https://sa.kapamilya.com/absnews/abscbnnews/media/abs-cbnnews/abscbnmaster/favicon.ico"><![endif]-->
<meta name="msapplication-TileColor" content="#ffffff">
<meta name="msapplication-TileImage" content="https://sa.kapamilya.com/absnews/abscbnnews/media/abs-cbnnews/abscbnmaster/favicon.ico">
<script type='text/javascript' src='//www.youtube.com/iframe_api'></script>

<script class="kxct" data-id="sr0c50od3" data-timing="async" data-version="3.0" type="text/javascript">
   window.Krux||((Krux=function(){Krux.q.push(arguments)}).q=[]);
   (function(){
      var k=document.createElement('script');k.type='text/javascript';k.async=true;
      k.src=(location.protocol==='https:'?'https:':'http:')+'//cdn.krxd.net/controltag/sr0c50od3.js';
      var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);
   }());
</script>


<script class="kxint" data-namespace="abscbn" type="text/javascript">
   window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);
   (function(){
      function retrieve(n){
         var k= 'kx'+'abscbn_'+n, ls=(function(){
            try {
               return window.localStorage;
            } catch(e) {
               return null;
            }
         })();
         if (ls) {
            return ls[k] || '';
         } else if (navigator.cookieEnabled) {
            var m = document.cookie.match(k+'=([^;]*)');
            return (m && unescape(m[1])) || '';
         } else {
            return '';
         }
      }
   Krux.user = retrieve('user');
   Krux.segments = retrieve('segs') ? retrieve('segs').split(',') : [];
   })();
</script>


<script type="text/javascript">
var PWT={}; //Initialize Namespace
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
var gptRan = false;
PWT.jsLoaded = function(){ //PubMatic pwt.js on load callback is used to load GPT
    loadGPT();
};
var loadGPT = function() {
    // Check the gptRan flag
    if (!gptRan) {
        gptRan = true;
        var gads = document.createElement('script');
        var useSSL = 'https:' == document.location.protocol;
        gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(gads, node);
    }
};
// Failsafe to call gpt
setTimeout(loadGPT, 500);
</script>
<script type="text/javascript">
 (function() {
     var purl = window.location.href;
     var url = '//ads.pubmatic.com/AdServer/js/pwt/159339/2302';
     var profileVersionId = '';
     if(purl.indexOf('pwtv=')>0){
         var regexp = /pwtv=(.*?)(&|$)/g;
         var matches = regexp.exec(purl);
         if(matches.length >= 2 && matches[1].length > 0){
             profileVersionId = '/'+matches[1];
         }
     }
     var wtads = document.createElement('script');
     wtads.async = true;
     wtads.type = 'text/javascript';
     wtads.src = url+profileVersionId+'/pwt.js';
     var node = document.getElementsByTagName('script')[0];
     node.parentNode.insertBefore(wtads, node);
 })();
</script>
<script>
  googletag.cmd.push(function() {
      var dfpWindow = window.location.href;
      var dfp_s = dfpWindow.split('/')[3] ? dfpWindow.split('/')[3] : 'home';
      var dfp_sub = dfpWindow.split('/')[4] ? dfpWindow.split('/')[4] : 'noValue';
      var dfp_list = dfpWindow.split('/')[5] ?
          dfpWindow.split('/')[5] : 'noValue';
      var dfp_article = dfpWindow.split('/')[7] ? dfpWindow.split('/')[7] : 'noValue';
      googletag.pubads().setTargeting("Section", dfp_s);
      googletag.pubads().setTargeting("SubSection", dfp_sub);
      googletag.pubads().setTargeting("Article",
          dfp_article);
      googletag.pubads().setTargeting("List", dfp_list);
      googletag.pubads().disableInitialLoad();
      googletag.pubads().collapseEmptyDivs(true);
      try {
          googletag.pubads().setTargeting("ksg", Krux.segments);
          googletag.pubads().setTargeting("kuid",
              Krux.user);
      } catch (error) {
          console.log("krux GPT failed to fetch");
      }
      googletag.pubads().enableLazyLoad({
          fetchMarginPercent: 0,
          renderMarginPercent: 0,
          mobileScaling: 0,
      });
      googletag.enableServices();
  });
</script>


<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KDVGXZ');</script>


<script>
var moatApi;
window.onMISReady = function(api) {moatApi = api;console.log(moatApi);}
</script>
<script>
(function(){function x(){for(var a=[8],b=1;2>=b;b++)a.push(8+b),a.push(8-b);a=a[Math.floor(Math.random()*a.length)];return{b:a,a:0==Math.floor(Math.random()*a)}}function h(a){var b=a=a.replace(":","");try{for(var c=0;100>c&&(a=decodeURIComponent(a),b!=a)&&!a.match(/^http(s)?\:/);c++)b=a}catch(d){}return a.replace(/(^\s+|\s+$)/g,"")}try{if(!location||!location.hostname||!location.pathname)return!1;var c=document.location.hostname.replace(/^www\./,""),q=function(){for(var a,b=document.getElementsByTagName("meta"),
c,d=0,e=b.length;d<e;d++)if(c=b[d],"og:title"===c.getAttribute("property")){a=c.getAttribute("content");break}a||(a=document.title||"Untitled");return a}(),b={},b=function(a,b,c){a.l1=b;a.l2=c;a.l3="__page__";a.l4="-";return a}(b,c,q),k=(new Date).getTime(),l=Math.floor(Math.random()*Math.pow(10,12)),m,d;d=x();m=d.a?d.b:0;b.zmoatab_cm=m;b.t=k;b.de=l;b.zMoatAB_SNPT=!0;var n;n=m?m:1;var r;r=d?d.a?!0:!1:!0;var c=[],y=(new Date).getTime().toString(35),t=[h(b.l1),h(b.l2),h(b.l3),h(b.l4)].join(":"),q=/zct[a-z0-9]+/i,
e="",f;for(f in b)b.hasOwnProperty(f)&&f.match(q)&&(e+="&"+f+"="+b[f]);var u=document.referrer.match(/^([^:]{2,}:\/\/[^\/]*)/),p=u?u[1]:document.referrer,z="https://w206arsk0kgv-a.akamaihd.net/"+y+".gif?e=17&d="+encodeURIComponent(t)+"&de="+l+"&t="+k+"&i=ABS_CBN_CONTENT1&cm="+n+"&j="+encodeURIComponent(p)+e+"&mp=1&ac=1&pl=1&bq=10&vc=2&cs=0",A="https://px.moatads.com/pixel.gif?e=17&d="+encodeURIComponent(t)+"&de="+l+"&t="+k+"&i=ABS_CBN_CONTENT1&cm="+n+"&j="+encodeURIComponent(p)+e+"&mp=0&ac=1&pl=1&bq=10&ad_type=img&vc=2&cs=0",
B="https://px.moatads.com/pixel.gif?e=17&d="+encodeURIComponent(t)+"&de="+l+"&t="+k+"&i=ABS_CBN_CONTENT1&cm="+n+"&j="+encodeURIComponent(p)+e+"&ku=1&ac=1&pl=1&bq=10&ad_type=img&vc=2&cs=0";r&&((new Image).src=z,(new Image).src=A);for(var v in b)c.push(v+"="+encodeURIComponent(b[v]));var c=c.join("&"),c=c+"&vc=2",g=document.createElement("script");g.type="text/javascript";g.async=!0;r&&(g.onerror=function(){(new Image).src=B});var w=document.getElementsByTagName("script")[0];w.parentNode.insertBefore(g,
w);g.src="https://z.moatads.com/abscbncontent871176416293/moatcontent.js#"+c}catch(a){try{var C="//pixel.moatads.com/pixel.gif?e=24&d=data%3Adata%3Adata%3Adata&i=MOATCONTENTABSNIPPET1"+e+"&vc=2&ac=1&k="+encodeURIComponent(a)+"&j="+encodeURIComponent(p)+"&cs="+(new Date).getTime();(new Image).src=C}catch(D){}}})();
</script>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
<script>
googletag.cmd.push(function() {
	var dfpWindow = window.location.href;
	var dfp_s = dfpWindow.split('/')[3] ? dfpWindow.split('/')[3] : 'home';
	var dfp_sub = dfpWindow.split('/')[4] ? dfpWindow.split('/')[4] : 'noValue';
	var dfp_list = dfpWindow.split('/')[5] ? dfpWindow.split('/')[5] : 'noValue';
	var dfp_article = dfpWindow.split('/')[7] ? dfpWindow.split('/')[7] : 'noValue';
	googletag.pubads().setTargeting("Section", dfp_s); 
    googletag.pubads().setTargeting("SubSection", dfp_sub);
	googletag.pubads().setTargeting("Article", dfp_article);
	googletag.pubads().setTargeting("List", dfp_list);
	googletag.pubads().disableInitialLoad();
	googletag.pubads().collapseEmptyDivs(true);
	googletag.pubads().enableLazyLoad({
		fetchMarginPercent: 0,
		renderMarginPercent: 0,
		mobileScaling: 0,
	});
    googletag.enableServices();
});
</script></head>
<body class="LTR ENUS ContentBody"><script>var p=window.location.pathname,t=document.title,mt=document.querySelector('meta[property="article:tag"]').getAttribute("content");!function(e,t,c,a,n,o,s){e.GoogleAnalyticsObject=n,e[n]=e[n]||function(){(e[n].q=e[n].q||[]).push(arguments)},e[n].l=1*new Date,o=t.createElement(c),s=t.getElementsByTagName(c)[0],o.async=1,o.src=a,s.parentNode.insertBefore(o,s)}(window,document,"script","https://www.google-analytics.com/analytics.js","ga"),ga("create","UA-74941230-1","auto"),ga("set","dimension1",mt),ga("send","pageview",{title:t,page:p}),_atrk_opts={atrk_acct:"q1E1k1acFH00Wr",domain:"abs-cbn.com",dynamic:!0},function(){var e=document.createElement("script");e.type="text/javascript",e.async=!0,e.src="https://d31qbv1cthcecs.cloudfront.net/atrk.js";var t=document.getElementsByTagName("script")[0];t.parentNode.insertBefore(e,t)}();var _comscore=_comscore||[];_comscore.push({c1:"2",c2:"7385337"}),function(){var e=document.createElement("script"),t=document.getElementsByTagName("script")[0];e.async=!0,e.src=("https:"==document.location.protocol?"https://sb":"http://b")+".scorecardresearch.com/beacon.js",t.parentNode.insertBefore(e,t)}();</script><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KDVGXZ" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<form method="post" action="/entertainment/08/03/20/marvin-agustin-reveals-greatest-reward-of-being-a-dad" id="form">
<input type="hidden" name="manScript_HiddenField" id="manScript_HiddenField" value="" />
<input type="hidden" name="__CMSCsrfToken" id="__CMSCsrfToken" value="JYObxhxZUCzcf7Ts+lqp/3UNJimSL9DrT2ohzHXQZhpkcEscRNQIZdwRurm6CCdvt5panQ2XXEgRez+ohhuKodjpy00=" />
<input type="hidden" name="lng" id="lng" value="en-US" />
<script type="text/javascript">
	//<![CDATA[

function PM_Postback(param) { if (window.top.HideScreenLockWarningAndSync) { window.top.HideScreenLockWarningAndSync(1080); } if(window.CMSContentManager) { CMSContentManager.allowSubmit = true; }; __doPostBack('m$am',param); }
function PM_Callback(param, callback, ctx) { if (window.top.HideScreenLockWarningAndSync) { window.top.HideScreenLockWarningAndSync(1080); }if (window.CMSContentManager) { CMSContentManager.storeContentChangedStatus(); };WebForm_DoCallback('m$am',param,callback,ctx,null,true); }
//]]>
</script>
<script src="/ScriptResource.axd?d=x6wALODbMJK5e0eRC_p1LSuQhSLI4ULKz5LGAHUMtMpy-Z-BO5ZbvLfBvG5SwrZh49VC9pgs9xfNSc8vI7xsQcUYMhxih1yheo8uNxamVDebEQ0Q0&amp;t=7c776dc1" type="text/javascript"></script>
<script type="text/javascript">
	//<![CDATA[

var CMS = CMS || {};
CMS.Application = {
  "isDialog": false,
  "isDebuggingEnabled": false,
  "applicationUrl": "/",
  "isRTL": "false",
  "imagesUrl": "/CMSPages/GetResource.ashx?image=%5bImages.zip%5d%2f"
};

//]]>
</script>
<input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="A5343185" />
<div id="ctxM">
</div>

<div id="wrapper">

<header class="main uninav-header uninav-default uninav-news">
<div class="header-fixed">
<div class="header-bar">
<button type="button" class="navbar-toggle collapsed header-nav-toggle" data-toggle="collapse" data-target="#header-collapse">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
<button id="uninav-toggle" type="button" class="navbar-toggle collapsed uninav-toggle pull-right">
<span class="sr-only">Toggle Universal Navigation</span>
<span class="uninav-icon-new uninav-icon-uninav"></span>
</button>
<div class="header-bar-inner">
<div class="logo">
<a href="/">
<img src="//sa.kapamilya.com/absnews/abscbnnews/media/abs-cbnnews/abscbnmaster/logo-abscbn.png" alt="ABS-CBN"> <span>News</span>
</a>
</div>
<ul class="header-social list-unstyled">
<li class="search-container-lg">
<div class="search-container">
<div class="search-form" autocomplete="off">
<input type="text" id="q1" name="q" onkeypress="return SubmitOnEnter(this,event,'q1')" placeholder="Search">
<input type="button" value="Search" onclick="SearchSite('q1')" class="uninav-icon uninav-icon-search">
</div>
</div>
</li>
<li><a href="https://www.facebook.com/abscbnNEWS/" rel="noopener noreferrer" target="_blank"><i class="uninav-icon uninav-icon-fb"></i> <span class="sr-only">facebook</span></a></li>
<li><a href="https://twitter.com/ABSCBNNews" rel="noopener noreferrer" target="_blank"><i class="uninav-icon uninav-icon-tw"></i> <span class="sr-only">twitter</span></a></li>
<li><a href="https://www.youtube.com/user/TheABSCBNNews" rel="noopener noreferrer" target="_blank"><i class="uninav-icon uninav-icon-yt" rel="noopener noreferrer" target="_blank"></i> <span class="sr-only">youtube</span></a></li>
<li><a class="sso-uninav-login" href="javascript:void(0)"><i class="uninav-icon-new uninav-icon-login"></i> <span class="sr-only">login</span></a></li>
</ul>
</div>
</div>
<nav id="header-collapse" class="header-collapse collapse">
<div class="header-nav">
<div class="search-container">
<div class="search-form" autocomplete="off">
<input type="text" id="q2" name="q" onkeypress="return SubmitOnEnter(this,event,'q2')" placeholder="Search">
<input type="button" onclick="SearchSite('q2')" value="Search" class="uninav-icon uninav-icon-search">
</div>
<script type="text/javascript" language="javascript">
							var cx = '017801961096448973220:dtv9a-rpb3a';
							function URLEncode (clearString) {
							  var output = '';
							  var x = 0;
							  clearString = clearString.toString();
							  var regex = /(^[a-zA-Z0-9_.]*)/;
							  while (x < clearString.length) {
								var match = regex.exec(clearString.substr(x));
								if (match != null && match.length > 1 && match[1] != '') {
									output += match[1];
								  x += match[1].length;
								} else {
								  if (clearString[x] == ' ')
									output += '+';
								  else {
									var charCode = clearString.charCodeAt(x);
									var hexVal = charCode.toString(16);
									output += '%' + ( hexVal.length < 2 ? '0' : '' ) + hexVal.toUpperCase();
								  }
								  x++;
								}
							  }
							  return output;
							}

							function SubmitOnEnter(myfield, e, q='q1')
							{
								var keycode;
								if (window.event)
									keycode = window.event.keyCode;
								else if (e)
									keycode = e.which;
								else
									return true;
								if (keycode == 13)
								{
									SearchSite(q);
									return false;
								}
								else
									return true;
							}
							function SearchSite(q)  
							{
								document.location.href='/Special-Pages/Search?q=' + URLEncode(document.getElementById(q).value);
							}
						</script>
</div>
<ul class="list-unstyled clearfix">
<li><a href="/">Home</a></li>
<li><a href="/news">News</a></li>
<li><a href="/business">Business</a></li>
<li><a href="/entertainment">Entertainment</a></li>
<li><a href="/life">Life</a></li>
<li><a href="/sports">Sports</a></li>
<li><a href="/overseas">Overseas</a></li>
<li><a href="/spotlight">Spotlight</a></li>
<li><a href="/weather">Weather</a></li>
<li class="hide-menu"><a href="/tv-patrol">TV Patrol</a></li>
<li class="hide-menu"><a href="/dzmm">DZMM</a></li>
<li class="hide-menu"><a href="/anc">ANC</a></li>
<li class="hide-menu"><a href="/ancx">ANCX</a></li>
</ul>
</div>
</nav>
</div>
<div id="mobile-uninav">
<section id="mobile-icons">
<div class="pull-right mobile-menu">
<a href="javascript:void(0);" class="link-uninav">
<span id="mobile-icon" class="icon uninav-icon-dashboard"></span>
</a>
</div>
<div class="pull-right">
<a href="javascript:void(0);" class="link-uninav">
<span id="mobile-icon" class="icon uninav-icon-new"></span>
</a>
</div>
<div class="pull-left">
<a href="//kapamilyaaccounts.abs-cbn.com/profile" class="link-uninav">
<span id="mobile-icon" class="icon uninav-icon-login-new"><p></p></span>
</a>
</div>
<div class="pull-right">
<a href="javascript:void(0);" class="link-uninav">
<span id="mobile-icon" class="icon uninav-icon-search-new"></span>
</a>
</div>
<div class="pull-left site-logo">
<a href="javascript:void(0);" class="link-uninav">
<span id="mobile-icon" class="icon news"></span>
</a>
</div>
</section>
</div>
</header>


<div class="main" role="main">

<div id="content">
<div id="title-value" style="display:none;">Marvin Agustin reveals greatest reward of being a dad
</div>
<script>
if(document.getElementById('title-value').innerHTML.trim() == "") {
   window.location = "/404?ref=marvin-agustin-reveals-greatest-reward-of-being-a-dad";
}
</script>
<div class="item-content-block">
<div id="div-gpt-ad-OOP">
<script>
            googletag.cmd.push(function() {
            var OOPslot = googletag.defineOutOfPageSlot('/2744311/ABSNews_OutofPage', 'div-gpt-ad-OOP').addService(googletag.pubads()); 
              googletag.enableServices();
              googletag.display('div-gpt-ad-OOP');
    		  googletag.pubads().refresh([OOPslot]);
          });
          </script>
</div>

<section class="ads-block leaderboard">
<div id="div-gpt-ad-SLB" style="font-size:0px !important;">
<script>
   var slbUnfilled = 'noValue', slbViewable = 'noValue';
   googletag.cmd.push(function() {
      var SLBmapping = googletag.sizeMapping()
         .addSize([970, 0], [[970, 90], [970,250],[728,90]])
         .addSize([728, 0], [728, 90])
         .addSize([0, 0], [[320, 50],[320,100]])
         .build();
      var SLBslot = googletag.defineSlot('/2744311/ABSNews_SuperLeaderboard', [[320, 50], [320,100], [728, 90], [970, 90]], 'div-gpt-ad-SLB').defineSizeMapping(SLBmapping).addService(googletag.pubads());
      googletag.enableServices();
      googletag.display('div-gpt-ad-SLB');
      googletag.pubads().refresh([SLBslot]);
      googletag.pubads().addEventListener('slotRenderEnded', function(event) {
         if (event.slot.getSlotElementId() == "div-gpt-ad-SLB") {
            slbUnfilled = event.isEmpty;
         }
      });
      googletag.pubads().addEventListener('impressionViewable', function(event) {
         if (event.slot.getSlotElementId() == "div-gpt-ad-SLB") {
            slbViewable = true;
         }
      });
   });
</script>
</div>
</section><div style='font-size:0px !important;'>
</div>


<section class="section-block section-content clearfix">
<div class="section-left-panel">
<article class="article-block animated-content sticker">

<div class="block-content" itemscope itemtype="https://schema.org/NewsArticle">
<div class="breadcrumb-block">
<p>
<a href="/">Home</a>
<span class="divider">&nbsp;&gt;&nbsp;</span>
<a href="/Entertainment">Entertainment</a>
</p>
</div>
<script type="application/ld+json">{"@context":"https://schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"URL","@id":"https://news.abs-cbn.com/entertainment/08/03/20/marvin-agustin-reveals-greatest-reward-of-being-a-dad"},"headline":"Marvin Agustin reveals greatest reward of being a dad","image":{"@type":"ImageObject","url":"https://sa.kapamilya.com/absnews/abscbnnews/media/2020/entertainment/08/03/marvin-agustin.jpg","width":950,"height":633},"dateCreated":"2020-08-03T04:27:47","datePublished":"2020-08-03T04:27:47","dateModified":"2020-08-03T04:27:48","author":{"@type":"Thing","name":"ABS-CBN News"},"creator":{"@type":"Organization","name":"ABS-CBN News"},"publisher":{"@type":"Organization","name":"ABS-CBN News","logo":{"@type":"ImageObject","url":"https://img.abs-cbnnews.com/assets/media/news-amp.png","width": 575,"height": 60}},"description":"Marvin Agustin is mostly known as the actor or the entrepreneur but not a lot of people know how he is a father to his twin sons.
&nbsp;
","articleSection":"Entertainment","inLanguage":"en_US","thumbnailUrl":"https://sa.kapamilya.com/absnews/abscbnnews/media/2020/entertainment/08/03/marvin-agustin.jpg","url":"https://news.abs-cbn.com/entertainment/08/03/20/marvin-agustin-reveals-greatest-reward-of-being-a-dad"}</script>
<meta itemprop="mainEntityOfPage" content="https://news.abs-cbn.com/entertainment/08/03/20/marvin-agustin-reveals-greatest-reward-of-being-a-dad" />
<meta itemprop="dateCreated" content="2020-08-03T04:27:47" />
<meta itemprop="datePublished" content="2020-08-03T04:27:47" />
<meta itemprop="dateModified" content="2020-08-03T04:27:48" />
<meta itemprop="headline" content="Marvin Agustin reveals greatest reward of being a dad - ABS-CBN News" />
<meta itemprop="name" content="Marvin Agustin reveals greatest reward of being a dad | ABS-CBN News" />
<meta itemprop="keywords" content="Marvin Agustin, I Feel U, parenting, Marvin Agustin reveals greatest reward of being a dad - ABS-CBN News" />
<meta itemprop="articleSection" content="Entertainment" />
<meta itemprop="url" content="https://news.abs-cbn.com/entertainment/08/03/20/marvin-agustin-reveals-greatest-reward-of-being-a-dad" />
<meta itemprop="description" content="Marvin Agustin is mostly known as the actor or the entrepreneur but not a lot of people know how he is a father to his twin sons.
&nbsp;
" />
<div itemprop="author" itemscope itemtype="https://schema.org/Person">
<meta itemprop="name" content="ABS-CBN News" />
</div>
<div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
<meta itemprop="url" content="https://sa.kapamilya.com/entertainment/abs-cbnent/media/abs-cbnent/news-abscbn-logo.gif">
</div>
<meta itemprop="name" content="ABS-CBN News">
</div>
<meta itemprop="image" content="https://sa.kapamilya.com/absnews/abscbnnews/media/2020/entertainment/08/03/marvin-agustin.jpg" />
<meta itemprop="thumbnailUrl" content="https://sa.kapamilya.com/absnews/abscbnnews/media/2020/entertainment/08/03/marvin-agustin.jpg" />
<div class="article-label clearfix">

</div>
<h1 class="news-title">Marvin Agustin reveals greatest reward of being a dad</h1>
<div class="author-block">
<h5 class="author-details"><span class="editor">ABS-CBN News</span></h5>
<div class="post-details">
<p class="timestamp-entry">Posted at <span class="date-posted">Aug 03 2020 12:27 PM</span></p>
</div>
</div>

<div class="news-share-block sharebar sticker clearfix">
<div id="sticker" data-sticky_column>
<p>Share</p>
<ul>
<li><a href="https://www.facebook.com/sharer/sharer.php?u=https://news.abs-cbn.com/entertainment/08/03/20/marvin-agustin-reveals-greatest-reward-of-being-a-dad" class="share sprite share-fb">Facebook</a></li>
<li><a href="https://twitter.com/intent/tweet?source=https://news.abs-cbn.com/entertainment/08/03/20/marvin-agustin-reveals-greatest-reward-of-being-a-dad&text=Marvin%20Agustin%20reveals%20greatest%20reward%20of%20being%20a%20dad:https://news.abs-cbn.com/entertainment/08/03/20/marvin-agustin-reveals-greatest-reward-of-being-a-dad&via=ABSCBNNews" class="share sprite share-tw">Twitter</a></li>
<li><a href="https://www.linkedin.com/shareArticle?mini=true&url=https://news.abs-cbn.com/entertainment/08/03/20/marvin-agustin-reveals-greatest-reward-of-being-a-dad&title=Marvin Agustin reveals greatest reward of being a dad&summary=Marvin Agustin is mostly known as the actor or the entrepreneur but not a lot of people know how he is a father to his twin sons.
&nbsp;
&source=https://news.abs-cbn.com/entertainment/08/03/20/marvin-agustin-reveals-greatest-reward-of-being-a-dad" class="share sprite share-in">LinkedIn</a></li>
</ul>
</div>
</div>
<div class="article-content" itemprop="articleBody">
<p>MANILA &ndash; Marvin Agustin is mostly known as the actor or the entrepreneur but not a lot of people know how he is a father to his twin sons.</p>
<p>In an interview with Toni Gonzaga for &ldquo;I Feel U,&rdquo; Agustin opened up about his role as a dad, and how having twins with his ex-girlfriend Tetet Dy has been a life changing experience for him.</p>
<p>&ldquo;&#39;Yun &#39;yung point ng buhay ng isang taong nagiging magulang na hindi na sarili mo &#39;yung iniisip mo. Bago ka maging magulang, ang iniisip mo ano ba ang magandang gawin ko, ano ba ang gusto ko. Kapag nagkaroon ka na ng anak, siya na &#39;yung dahilan kung bakit mo gagawin &#39;yung mga bagay na gusto mong gawin,&rdquo; he said.</p>
<p>While he and Dy are no longer a couple, Agustin said they make it a point to always be present in their children&rsquo;s life.</p>
<p>&ldquo;Kami kasi ni Tet, ever since parang naging mature kami at naging responsible kami sa pag-handle ng roles namin as parents,&rdquo; Agustin said.</p>
<blockquote class="instagram-media" data-instgrm-permalink="https://www.instagram.com/p/B4rZ0l7nj68/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:540px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);">
<div style="padding:16px;">
<div style=" display: flex; flex-direction: row; align-items: center;">
<div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;">&nbsp;</div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;">
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;">&nbsp;</div>
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;">&nbsp;</div>
</div>
</div>
<div style="padding: 19% 0;">&nbsp;</div>
<div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><a href="https://www.instagram.com/p/B4rZ0l7nj68/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"><svg height="50px" version="1.1" viewbox="0 0 60 60" width="50px" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g fill="none" fill-rule="evenodd" stroke="none" stroke-width="1"><g fill="#000000" transform="translate(-511.000000, -20.000000)"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></a></div>
<div style="padding-top: 8px;">
<div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"><a href="https://www.instagram.com/p/B4rZ0l7nj68/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank">View this post on Instagram</a></div>
</div>
<div style="padding: 12.5% 0;">&nbsp;</div>
<div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;">
<div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);">&nbsp;</div>
<div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;">&nbsp;</div>
<div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);">&nbsp;</div>
</div>
<div style="margin-left: 8px;">
<div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;">&nbsp;</div>
<div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)">&nbsp;</div>
</div>
<div style="margin-left: auto;">
<div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);">&nbsp;</div>
<div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);">&nbsp;</div>
<div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);">&nbsp;</div>
</div>
</div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center; margin-bottom: 24px;">
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 224px;">&nbsp;</div>
<div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 144px;">&nbsp;</div>
</div>
<p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;"><a href="https://www.instagram.com/p/B4rZ0l7nj68/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none;" target="_blank">A post shared by M A R V I N (@marvinagustin)</a> on <time datetime="2019-11-10T08:27:18+00:00" style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;">Nov 10, 2019 at 12:27am PST</time></p>
</div>
</blockquote>
<p><script async src="https://www.instagram.com/embed.js" type="text/javascript"></script>&ldquo;Pinangako lang namin ni Tet sa isa&rsquo;t isa na we may not be like the other families and typical parents na magkasamang palalakihin &#39;yung mga anak, [pero] dapat may extra effort to be best friends and to make sure na maganda &#39;yung relationship namin,&rdquo; he added.</p>
<p>When asked what he thinks is the greatest reward of being a dad, Agustin said: &ldquo;[&#39;Yung] nakikita mong masaya &#39;yung mga anak mo. Nakikita mo na nagde-develop sila on their own, masaya sila sa ginagawa na nila.&rdquo;</p>
<p>For Agustin, it gives him so much joy knowing that his twins are able to stand on their own feet.</p>
<p>&ldquo;Na-prepare mo sila sa mundo,&rdquo; he said.</p>
</div>

<div class="news-share-block sharebar sticker clearfix">
<div id="sticker" data-sticky_column>
<p>Share</p>
<ul>
<li><a href="https://www.facebook.com/sharer/sharer.php?u=https://news.abs-cbn.com/entertainment/08/03/20/marvin-agustin-reveals-greatest-reward-of-being-a-dad" class="share sprite share-fb">Facebook</a></li>
<li><a href="https://twitter.com/intent/tweet?source=https://news.abs-cbn.com/entertainment/08/03/20/marvin-agustin-reveals-greatest-reward-of-being-a-dad&text=Marvin%20Agustin%20reveals%20greatest%20reward%20of%20being%20a%20dad https://news.abs-cbn.com/entertainment/08/03/20/marvin-agustin-reveals-greatest-reward-of-being-a-dad&via=ABSCBNNews" class="sprite share-tw">Share on Twitter</a></li>
<li><a href="https://www.linkedin.com/shareArticle?mini=true&url=https://news.abs-cbn.com/entertainment/08/03/20/marvin-agustin-reveals-greatest-reward-of-being-a-dad&title=Marvin Agustin reveals greatest reward of being a dad&summary=Marvin Agustin is mostly known as the actor or the entrepreneur but not a lot of people know how he is a father to his twin sons.
&nbsp;
&source=https://news.abs-cbn.com/entertainment/08/03/20/marvin-agustin-reveals-greatest-reward-of-being-a-dad" class="share sprite share-in">LinkedIn</a></li>
</ul>
</div>
</div>
<div id="internal-tags" style="display:none;">Marvin Agustin, I Feel U, parenting
</div><div class="article-metakey">
<b>Read More:&nbsp;</b>
<a href="/list/tag/Marvin-Agustin">Marvin Agustin&nbsp;&nbsp;</a>
<a href="/list/tag/I-Feel-U">I Feel U&nbsp;&nbsp;</a>
<a href="/list/tag/parenting">parenting&nbsp;&nbsp;</a>
</div>
</div>
</article>
</div>
<div class="section-right-panel animated-content">
<div class="sidebar sticker">
<ul class="tabs clearfix">
<li data-tab="tabs-latest" class="tabs-latest current">
<h2><a href="#tabs-latest">LATEST NEWS</a></h2>
</li>
<li data-tab="tabs-most" class="tabs-most" style="display:none;">
<h2><a href="#tabs-most">MOST READ</a></h2>
</li>
</ul>
<div class="tabs-inner current" id="tabs-latest">
<ul><li>
<p class="title-sidebar"><a href="/sports/08/23/20/football-psg-face-bayern-hurdle-in-quest-for-first-champions-league-title">Football: PSG face Bayern hurdle in quest for first Champions League title</a></p>
<p class="timestamp-entry"><time class="date-posted timeago" datetime="2020-08-23T22:04:49+08:00">August 23, 2020</time></p>
</li><li>
<p class="title-sidebar"><a href="/news/08/23/20/28-manggagawa-sa-pabrika-sa-bataan-nagpositibo-sa-covid-19">28 manggagawa sa pabrika sa Bataan, nagpositibo sa COVID-19</a></p>
<p class="timestamp-entry"><time class="date-posted timeago" datetime="2020-08-23T21:59:58+08:00">August 23, 2020</time></p>
</li><li>
<p class="title-sidebar"><a href="/business/08/23/20/business-groups-hail-supreme-court-ruling-vs-warrantless-searches-and-seizures">Business groups hail Supreme Court ruling vs warrantless searches and seizures</a></p>
<p class="timestamp-entry"><time class="date-posted timeago" datetime="2020-08-23T21:58:44+08:00">August 23, 2020</time></p>
</li><li>
<p class="title-sidebar"><a href="/news/08/23/20/lorenzana-lashes-back-at-china-over-alleged-provocations-in-west-ph-sea">Lorenzana lashes back at China over alleged provocations in West PH Sea</a></p>
<p class="timestamp-entry"><time class="date-posted timeago" datetime="2020-08-23T21:56:18+08:00">August 23, 2020</time></p>
</li><li>
<p class="title-sidebar"><a href="/sports/08/23/20/uaap-aldin-ayo-fully-cooperating-with-probe-on-sorsogon-bubble">UAAP: Aldin Ayo fully cooperating with probe on 'Sorsogon bubble'</a></p>
<p class="timestamp-entry"><time class="date-posted timeago" datetime="2020-08-23T21:48:17+08:00">August 23, 2020</time></p>
</li><li>
<p class="title-sidebar"><a href="/news/multimedia/photo/08/23/20/no-face-shield-no-entry">No face shield, no entry</a></p>
<p class="timestamp-entry"><time class="date-posted timeago" datetime="2020-08-23T21:23:59+08:00">August 23, 2020</time></p>
</li><li>
<p class="title-sidebar"><a href="/sports/08/23/20/uaap-ayo-breaks-silence-says-it-was-best-to-part-ways-with-cansino">UAAP: Ayo breaks silence, says it was best to part ways with Cansino</a></p>
<p class="timestamp-entry"><time class="date-posted timeago" datetime="2020-08-23T21:15:57+08:00">August 23, 2020</time></p>
</li><li>
<p class="title-sidebar"><a href="/news/08/23/20/uk-brazil-3-pang-ibang-bansa-inalis-ang-travel-restriction-sa-mga-pinoy">UK, Brazil, 3 pang ibang bansa inalis ang travel restriction sa mga Pinoy</a></p>
<p class="timestamp-entry"><time class="date-posted timeago" datetime="2020-08-23T20:47:10+08:00">August 23, 2020</time></p>
</li><li>
<p class="title-sidebar"><a href="/news/08/23/20/covid-19-cases-sa-pilipinas-nasa-higit-189000-na">COVID-19 cases sa Pilipinas nasa higit 189,000 na</a></p>
<p class="timestamp-entry"><time class="date-posted timeago" datetime="2020-08-23T20:43:43+08:00">August 23, 2020</time></p>
</li><li>
<p class="title-sidebar"><a href="/overseas/multimedia/photo/08/23/20/charlotte-uprising-protest-republican-convention">Protest ahead of the Republican Convention</a></p>
<p class="timestamp-entry"><time class="date-posted timeago" datetime="2020-08-23T20:34:42+08:00">August 23, 2020</time></p>
</li><li>
<p class="title-sidebar"><a href="/life/08/23/20/92-anyos-na-lola-sa-negros-occidental-gumaling-sa-covid-19">92 anyos na lola sa Negros Occidental, gumaling sa COVID-19</a></p>
<p class="timestamp-entry"><time class="date-posted timeago" datetime="2020-08-23T20:28:40+08:00">August 23, 2020</time></p>
</li><li>
<p class="title-sidebar"><a href="/news/multimedia/photo/08/23/20/mass-in-baclaran-church-amid-stricter-gcq">Hearing Mass in Baclaran as Metro Manila shifts to GCQ</a></p>
<p class="timestamp-entry"><time class="date-posted timeago" datetime="2020-08-23T20:23:33+08:00">August 23, 2020</time></p>
</li><li>
<p class="title-sidebar"><a href="/life/08/23/20/pia-wurtzbach-shares-sweet-travel-photos-with-jeremy-jauncey-on-his-birthday">Pia Wurtzbach shares sweet travel photos with Jeremy Jauncey on his birthday</a></p>
<p class="timestamp-entry"><time class="date-posted timeago" datetime="2020-08-23T20:19:10+08:00">August 23, 2020</time></p>
</li><li>
<p class="title-sidebar"><a href="/sports/08/23/20/japan-athletes-give-tokyo-olympic-stadium-a-test-run">Japan athletes give Tokyo Olympic stadium a test run</a></p>
<p class="timestamp-entry"><time class="date-posted timeago" datetime="2020-08-23T19:38:03+08:00">August 23, 2020</time></p>
</li><li>
<p class="title-sidebar"><a href="/news/08/23/20/nagpanggap-na-recruiter-ng-mga-pulis-huli-sa-cagayan">Nagpanggap na recruiter ng mga pulis huli sa Cagayan</a></p>
<p class="timestamp-entry"><time class="date-posted timeago" datetime="2020-08-23T19:12:25+08:00">August 23, 2020</time></p>
</li><li>
<p class="title-sidebar"><a href="/video/news/08/23/20/iatf-humingi-ng-tulong-sa-simbahan-para-sa-mga-nakararanas-ng-depresyon">IATF humingi ng tulong sa simbahan para sa mga nakararanas ng depresyon</a></p>
<p class="timestamp-entry"><time class="date-posted timeago" datetime="2020-08-23T19:07:29+08:00">August 23, 2020</time></p>
</li><li>
<p class="title-sidebar"><a href="/entertainment/08/23/20/former-pgt-finalist-wows-bts-with-dance-cover-of-dynamite">Former 'PGT' finalist wows BTS with dance cover of 'Dynamite'</a></p>
<p class="timestamp-entry"><time class="date-posted timeago" datetime="2020-08-23T18:11:29+08:00">August 23, 2020</time></p>
</li><li>
<p class="title-sidebar"><a href="/sports/08/23/20/target-on-his-back-no-problem-for-jalen-green">Target on his back? No problem for Jalen Green</a></p>
<p class="timestamp-entry"><time class="date-posted timeago" datetime="2020-08-23T18:06:30+08:00">August 23, 2020</time></p>
</li><li>
<p class="title-sidebar"><a href="/news/08/23/20/officials-who-recovered-from-covid-19-tout-need-to-inform-contacts-right-away">Officials who recovered from COVID-19 tout need to inform contacts right away</a></p>
<p class="timestamp-entry"><time class="date-posted timeago" datetime="2020-08-23T18:03:10+08:00">August 23, 2020</time></p>
</li><li>
<p class="title-sidebar"><a href="/entertainment/08/23/20/its-here-sneak-peek-of-zack-snyders-justice-league-cut">It's here! Sneak peek of Zack Snyder's 'Justice League' cut</a></p>
<p class="timestamp-entry"><time class="date-posted timeago" datetime="2020-08-23T17:48:14+08:00">August 23, 2020</time></p>
</li> </ul>
</div><div class="tabs-inner" id="tabs-most">
<ul id="most-read-contents">
</ul>
</div>
<div id="ad-option-sidebar">
<div id="div-gpt-ad-MRECLR"></div>
</div>
<div class="brand-news-block desktop"><div class="OUTBRAIN" data-src="https://news.abs-cbn.com/entertainment/08/03/20/marvin-agustin-reveals-greatest-reward-of-being-a-dad" data-widget-id="SB_1" data-ob-template="ABS-CBN"></div>
<script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script></div>
<div id="ad-option-sidebar">
<div id="div-gpt-ad-MRECSticky"></div>
</div>
</div>
</div>
</section>

</div>
</div>
<a href="" id="next">next</a>
</div>


<div class="section-page">
<section class="brand-news-full scroll mobile">
</section>
</div>
<div class="section-block article-footer" id="footer-widget-container"><script>
var s = document.querySelector('meta[name="article-tags"]').getAttribute("content").toLowerCase();
if( /Android|webOS|iPhone|iPad|iPod|BlackBerry|IEMobile|Opera Mini/i.test(navigator.userAgent) == true) {
   if(s.search("bestiality") == -1 && s.search("boy boso") == -1 && s.search("danica torres") == -1 && s.search("nude") == -1 && s.search("sex") == -1 && s.search("adult content") == -1) {
     var csd = document.createElement("div");
      csd.setAttribute("data-crowdynews-widget", "ABSCBN_abs-cbn-news");
      csd.setAttribute("id", "c_container_mobile");
      document.getElementById("footer-widget-container").appendChild(csd);
      
      var crs = document.createElement("script");
      crs.type = "text/javascript";
      crs.src = "//widget.crowdynews.com/ABSCBN_abs-cbn-news.js";
      document.getElementById("c_container_mobile").appendChild(crs);
      console.log('generate crowdynews for mobile');
   } else {
      console.log('adult content');
   }
}
</script><script>
var s = document.querySelector('meta[name="article-tags"]').getAttribute("content").toLowerCase();
if( /Android|webOS|iPhone|iPad|iPod|BlackBerry|IEMobile|Opera Mini/i.test(navigator.userAgent) == false) {
   if(s.search("bestiality") == -1 && s.search("boy boso") == -1 && s.search("danica torres") == -1 && s.search("nude") == -1 && s.search("sex") == -1 && s.search("adult content") == -1) {
     var csd = document.createElement("div");
      csd.setAttribute("data-crowdynews-widget", "ABSCBN_abs-cbn-news");
      csd.setAttribute("id", "c_container");
      document.getElementById("footer-widget-container").appendChild(csd);
      
      var crs = document.createElement("script");
      crs.type = "text/javascript";
      crs.src = "//widget.crowdynews.com/ABSCBN_abs-cbn-news.js";
      document.getElementById("c_container").appendChild(crs);
      console.log('generate crowdynews');
   } else {
      console.log('adult content');
   }
}
</script><div class="OUTBRAIN" data-src="https://news.abs-cbn.com/entertainment/08/03/20/marvin-agustin-reveals-greatest-reward-of-being-a-dad" data-widget-id="AR_6" data-ob-template="ABS-CBN"></div>
<div class="OUTBRAIN" data-src="https://news.abs-cbn.com/entertainment/08/03/20/marvin-agustin-reveals-greatest-reward-of-being-a-dad" data-widget-id="TR_2"></div></div>


<footer class="main clearfix">
<div class="holder">
<p class="left">© 2020 ABS-CBN Corporation. All Rights Reserved.</p><p class="right"><a href="https://www.abs-cbn.com/corporate" rel="noopener noreferrer" target="_blank">About</a><a href="https://www.abs-cbn.com/corporate" rel="noopener noreferrer" target="_blank">Careers</a><a href="https://www.abs-cbn.com/privacy?screen=privacy" rel="noopener noreferrer" target="_blank">Privacy</a><a href="https://www.abs-cbn.com/privacy?screen=terms" rel="noopener noreferrer" target="_blank">Terms</a><a href="https://www.abs-cbn.com/corporate" rel="noopener noreferrer" target="_blank">Contact Us</a><a href="https://advertise.abs-cbn.com" rel="noopener noreferrer" target="_blank">Advertise With Us</a></p>
</div>
</footer>

</div>


<script type="text/javascript" src="https://code.jquery.com/jquery-3.5.0.min.js"></script>

<script src="//assets.abs-cbn.com/universalnav/uninav-v4.2.0.js"></script>
<script type="text/javascript" async="true" src="//img.abs-cbnnews.com/assets/scripts/slick.min.js"></script>
<script type="text/javascript" async="true" src="//img.abs-cbnnews.com/assets/scripts/jquery.timeago.js"></script>
<script type="text/javascript" async="true" src="//img.abs-cbnnews.com/assets/scripts/cookie.js"></script>
<script type="text/javascript" async="true" src="//img.abs-cbnnews.com/assets/scripts/article.20200708.js"></script>
<script type="text/javascript" async="true" src="//widgets.outbrain.com/outbrain.js"></script>
<script>
$(document).ready(function() {
    $.getScript("//img.abs-cbnnews.com/assets/scripts/master.20200817.js");
});
</script>
<script type="text/javascript">
//<![CDATA[
(function() {var fn = function() {$get("manScript_HiddenField").value = '';Sys.Application.remove_init(fn);};Sys.Application.add_init(fn);})();//]]>
</script>
<script>
   var SLBID= 'div-gpt-ad-SLB'; 
   var $el= $('#' + SLBID); 
   var gt;
   var slbInt, timer;
   $(window).scroll(function (e) {
      //console.log("unfilled is " + slbUnfilled);
      //console.log("viewable is " + slbViewable);
      clearTimeout(gt);
      gt= setTimeout(function () {
         //console.log("height", $el.height());
         if ($el.height() < 250 && slbUnfilled == false) {
            if ($(this).scrollTop() > 100 && !$el.hasClass("sticky-slb")) {
               $el.addClass("sticky-slb");
               $('.sticky-slb').append("<div id='ad-close'>&#10006;</div>");
               $('#ad-close').on('click',function(e){e.preventDefault();$('.sticky-slb').remove();});				
               $el.slideDown('fast');
               timer= 10;
               slbInt= setInterval(function () {
                  $(".ctr").html(--timer);
                  if (timer <= 0)
                  clearInterval(slbInt);
               }, 10000);
               slbt1= setTimeout(function () {
                  $el.slideUp('fast');
                  clearInterval(slbInt);
                  $(".ctr").remove();
                  slbt2= setTimeout(function () {
                     $el.css({ 'display': 'block' });
                     clearTimeout(slbt2);
                     tr= false;
                  }, 200);
                  $el.remove();
               }, 17000);
            }
         }
      }, 50)		 
   });
</script>
<script type="text/javascript">
    $(function() {
        var params = {
            // Request parameters
        };
      
        $.ajax({
            url: "https://oneottprodapi.azure-api.net/news-analytics/news/pageviews",
            beforeSend: function(xhrObj){
                // Request headers
                xhrObj.setRequestHeader("Ocp-Apim-Subscription-Key","d3958ffcd988470aa6dfa85f9af0ea19");
                xhrObj.setRequestHeader("Access-Control-Allow-Origin","https://news.abs-cbn.com");
                xhrObj.setRequestHeader("Access-Control-Allow-Methods","POST, GET");
            },
            type: "GET",
            success: function(data) {
               if(data.length < 1) {
                  $(".tabs-most").hide();
               } else {
                   $(".tabs-most").show();
                  for(var i = 0; i < 20; i++){
                     if(data[i][1]!="news.abs-cbn.com/"){
                      var t = data[i][0];
                      var u = data[i][1];
                      $("#most-read-contents").append("<li><p class=\"title-sidebar\"><a href=\"https://"+u+"\">"+t.replace(" | ABS-CBN News", "")+"</p></li>");
                     }
                  }
               }
           },
           error: function() {
               $(".tabs-most").hide();
           }
        });
    });
</script> <input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="mWdO1957r2uKtTAZ9EUqxZboC0oourw7Y79VmcP+Me0VfRb83iAxy81qjBJWPWU/N7ibrLnR0lRZjuL4nssuSRAcKP8oWnyN3SEKcoVlqT/9mVWpjRbk7N/C2M9q9BmwDbUpu4u4Pb0jdWzWTG/dunKoBOt4AwSzqjqjYc3HmgdetV0PVEukCSGr3C335pPhfVIwKUuquBWBbxV1EWAxIbFBu5EBCMnUSn8z6bQpjYxC2RofWmfVcljmIoZbeUgHkkCmxlgHOiGxA+oazDHt/9fp8vzSmeKHSbnLeIt4bTyVm5v7LKHO8BnVGbgPleluQsmaRlrniJ/AARnwfMIflh2kb9y4BgJpIMuYV5C+rVnaRSIJhuzK5z66vgIA2RnGomC/TA==" />
<script type="text/javascript"> 
      //<![CDATA[
      if (window.WebForm_InitCallback) { 
        __theFormPostData = '';
        __theFormPostCollection = new Array();
        window.WebForm_InitCallback(); 
      }
      //]]>
    </script>
</form>
</body>
</html>
